Yoshihiro’s 5.55 & 6.00 FW Game Decrypter V2 Released.

Share
PSP Game Decrypter v2 Released. Patch 5.55 & 6.00 Games to work on CFW.

PSP v2 Released. Patch 5.55 & 6.00 Games to work on CFW.

Yoshihiro has released Version two of his Game Decrypter for PSP games that require firmware 5.55 and firmware 6.00 to run. This application allows you to patch the firmware 5.55 and firmware 6.00 eboots in order to run on to B2. It allows you to also run 5.55 and 6.00 FW games on your ChickHEN R2 / Custom Firmware 5.03 GEN-A PSP-3000.

This latest version includes fixes so users should have less issues running certain newer games. There are report that CFWEnabler will also run some games. So try that first if you have it installed and if you do decide to use Custom Firmware Enabler 3.60, please uninstall it first!!

Need help?

Source: PSPGen


Download: Yoshihiro's Firmware 5.55 & 6.00 Game Decrypter V2
(Yoshihiro's Firmware 5.55 & 6.00 Game Decrypter V2 - 53.1 KiB - 56,453 Hits)



Download: UMD Gen 4
(UMD Gen 4 - 1.1 MiB - 146,829 Hits)

Similar Posts:

  • None Found

  • Sgtplatypus

    I Thought Id just let people know i got star wars clone wars republic heroes to work on my psp 3000 with cfe 3.60 works great thanks Yoshihiro

  • kewalshah27

    i want psp 3000 downgrader………………….plzzzz…….hen,alex everyone find it……plzzz

  • Pingback: Eboot Patcher. Patch decrypted eboots to work with CFW 5.00 M33, PSP Hacks - PSP Slim Hacks

  • ACidGaMbiT

    Is PSP 3007 with firmware 5.50 hackable / downgradable already.

  • annoury

    will my psp 3001 / ofw 6.10 can be used wth the apps above .. if it was a “go” thn i would tk the risk to do it by ref the tutorial gvn & will buy an ori umd game 1st too. …

  • ikidums187

    i/dont/realy/understand/this..can/someone/help/me??/my/psp-3000/ver/is/chickHEN/gen-C./i/want/to/play/5.50gen-d/games/like/fifa/2010..btw,my/space/bar/is/broken…could/this/help/me/play/fifa10?