WIP: Downgrade PSP FW 6.35 to 6.20 with Hellcat’s recovery flasher 1.65 Beta

Share

’s back on the scene and working on a new dubbed version 1.65 Beta. This beta will feature a Firmware to Firmware 6.20 Downgrader. It’s run under 6.35 HEN via Minna no Sukkiri demo exploit. This is demonstrated in Hellcat’s video demo above. Running 6.35 HEN, then his Recovery Flasher and downgrading from 6.35 to 6.20. At this stage its a work in progress beta and still to be tested some what. Its only been tested on PSP Slim’s so far and no TA88v3 models.

We will keep you posted on any progress and the release date when know.

Via: Hellcat’s twitter

Similar Posts:

  • None Found

Gamer Headlines
  • http://gnhtmu abdouisawesome

    that is awesome

    • IRON.ME

      IT WILL BE RELEASED TONIGHT!!

  • http://www.iwantsixpackabs.com DEVASTATOR

    WICKED cool

  • CarLover

    Works on a PSP 3003 4G? (TA-093)

    • Imonar

      i cant believe that people are so stupid omg read the description n00bs

      • CarLover

        IT DOES NOT SAY IT WON’T WORK ON IT, READ IT SAYS NOT YET BEEN TESTED ON THESE MODELS! SO I WANTED TO KNOW HAD ANYONE TESTED IT, IDIOT!

      • hasu

        randomly calling people noobs is so wrong ..
        it’s always appropriate to ask ..
        some people want to know better ..

      • mayowas123

        Be quiet just tell him if he doesnt know tell him i dont even know myself calling people n00bz huh people who call n00bz these days

  • kioshii

    woooooooooot

  • NekoNeko

    If i dowgrade my psp from 6.35 to 6.20, can i play online games on 6.20TN-B? Because the 6.3x PRO can.

    • Imonar

      u need TN-C to play online games i think

      • CarLover

        TN-C is not out yet, though.

      • NekoNeko

        ok so i stay on 6.31 PRO :)

    • Avnit

      Yes you can play games on TN-B by using prometheus iso loader.

      • maumau

        you can even use prometheus iso loader on 6.35 pro using sukkiri’s exploit

  • http://www.venten.webs.com PSPdude

    Coldbird was wrong about 6.35 downgrade! :-)

    • CarLover

      Yep. I’m glad he was wrong!

      • http://www.venten.webs.com PSPdude

        Hahaha! but i think he sayed ’bout 3ks and go ’cause on twitter he told it is (till now) only compatible with 1k and 2k non ta-088v3

  • DutchOtaku

    i want it !
    i have a psp 3004 (gray) with 6.35 (PRO).
    and i want 6.20 back becouse the CXMB themes

  • hfhfhgfkfh55563

    Haha u only figured how to downgrade now! I did it long ago without this beta and why didnt u listen to me I mean u want to wait until 6.20 tnc to come out but YOU CAN GET FLIPPING CFW 5.00 M33 WITH HEN WHAT THE HELL DONT U GUYS UNDERSTAND! JUST USE HELLCATS PANDORA INSTALLER AND PSP GRADER ARE U THEN THAT SILLY OR WHAT! OPEN YOUR EYES!

    • hacktester

      Hahaha you will only figure out now that HELLCATS PANDORA INSTALLER works only for PSP 1000/2000!
      And if you would’ve been such a smart ass as you claim to be,you would’ve know that you can downgrade ANY PSP 1000/2000 with ANY Firmware since 2005!You dont even need the HEN to downgrade,you can just buy a Pandora Baterry and go back to 5.00.We’re talking here about the new models,no one is intrested in downgrading old PSP’s anymore.
      So ,you waited for the HEN about an year just to downgrade a PSP 1000/2000.Say,whos silly now?

      • http://pspslimhacks ghosthunter187

        @hacktester u beat me to the punch line bro i was gonna say the samething lmfao

    • MrZer017

      *facepalm*

      • andy b

        i think someone needs the “Epic Facepalm Compilation”……..hacktester dishing out the justice

        http(://www).youtube(.)com/watch?v=RA06Z5e1ZFc&NR=1
        just remove the ()’s

    • dyey-em

      don’t do this kind of thing, you just caused confusion to new users of psp. and why do you do all caps? first of all, your method is not applicable to all models of psp, so stop posting or re-write your post.

    • Fargaite

      In other words, you’re a retard. Ok.

    • maumau

      what a stupid guy

  • http://wiifriendcodes.tk McNuggetz

    yo can sum1 pm me on youtube when this is tested on a 3000 6.35 youtube.com/supergothmarco

  • http://www.pspcfw.de flofrucht

    you could really add me as source ,.-.

  • hfhfhgfkfh55563

    YES BUT SOME NOOBS HAVE A PSP PHAT OR SLIM BUT STILL DONT KNOW THAT THEY CAN USE THIS HEN TO GET CFW WITHOUT BUYING A PANDORA BATTERY IT WAS ACTUALLY FOR THEM ! AND YES I WAITED! WHAT? U EXPECT ME TO BUY A PANDORA TO JUST USE ONCE? AND NEVER AGAIN? HAHA THATS A WASTE OF MONEY! IF YOU HAVE MONEY THEN U MIGHT AS WELL NOT HACK YOUR PSP AND GO BUY FLIPPING GAMES! SILLY BILLY!

    • AboveMe

      Pandora = $5
      Games = $20 average
      Hacked = Piracy

      • whatever

        Actually US courts came to the consensus that hacking your own device is not illegal no matter what. It is illegal however to steal games or download roms for games you dont own. Doesnt anyone read the news on this stuff? It was passed last year on Iphones………

    • dyey-em

      *facepalm*

    • LOL

      You have been pwned. Please go away and stop making yourself look even more stupid.

  • dimy93

    h ttp://pb.lui.li/6ca3107a53a56490
    the changelog

  • PSP-Tester

    Would be nice if it works to flash to GEN-D (on hackable PSPs) from 6.35. Would make it a lot easier to go back when testing new stuff etc.

  • Weeltan

    Helcat FTW !!

  • AIM

    I have one question, WHY AREN’T THEY WORKING ON NON HACKABLE PSP MODELS? I mean like, ever since the PSP TA88v3 and the other non-hackable motherboards, they have given up and worked on the other hackable models, I think there is ENOUGH hacks for the hackable PSP’s, can they start working on something that can be USEFUL?

  • Michael

    Will this work on psp go? What is a TA88v3 model?

    • Reynkz

      I don’t think u should try, its only been test on slim 2000, and TA88v3 model is a type of PSP that doesn’t work with pandora battery and most custom firmware( PSP 3000 and PSP 2000 v3 and PSP Go somewhat i believe).

  • Pete

    Hellcat, **** yeah! You know it’s good when you see his name :)

  • Mister L

    Fck MAN! nothing ever comes out for 3000′s

    • SuperstarX64

      I feel your pain… I also have an un(fully)hackable PSP and I guess ChickHEN R2 has been the best thing for it so far… (though it’s old and “abandoned”…)

    • dyey-em

      motherboard is different and so does the lcd. so it’s harder to code for psp3k. i too am stucked with chickhen r2, but it is better than nothing

    • maumau

      i feel ur goddamn pain .. i too is stuck on R2. hahaha lets just wait for hacks and maybe just maybe they can fully hack BRITEs

  • random pspdude

    yes, my prayers have been answered :)

  • http://ShadowHacks.tk MarcoInsane15

    WOW YALL REALLY NEED TO WORK ON SOME NON HACKABLE PSP’s LIKE BRITE CAUSE U CAN HACK ALMOST ANY 1k OR 2k

    • whatever

      1st Stop using all caps. It makes you look like an idiot. 2nd All 1k’s are hackable so use proper english and separate your thoughts into two coherent sentences.

  • maycee

    waiting for so long and its here… cant wait for the psp go version of this downgrader :)

    • Go! Fan

      I agree…they dont make shit for Go’s! Lol

  • F8ng

    Well done Hellcat. The homebrew scene stays alive thanks to guys like u.

  • Gerardnr

    If anyone Wants to play PSX on 6.20TN-B. Search up PS1P Owned

    • Gerardnr

      Its Pretty Slow but still works Tested Final Fantasy VII

      • PSPLover

        Thanks it worked but your right, it is slow

  • CreativeMindMedias

    Well i hate to rain in on all your parade’s but recently Fail0v3rfl0w (which is a group of ppl who are hackers) have discovered the athorization key’s for the PS3 and the PSP meaning than eventually when someone has decyphered the code we will be able to update to a CFW on a psp 3000 and psp GO permanently (wont have to reboot the hack(HEN) everytime you reboot your PSP) . In other words using this key to sign our own games and programs for the PSP system will destroy Sony’s attempts to patch our exploits and will aslo void the need for an exploit because we can just register our own programs with this key.

    It’s a major turn in hacking the PSP!

    And also for those who didnt know… a TA-088v3 motherboard was the last version of the PSP 2000 model before the initial release of the PSP 3000. Both the PSP 3000 and the PSP Go models to date run on a TA-092v1 motherboard.

    • dyey-em

      there’s the ta-093, the so called 4g motherboards for the psp3k, i don’t know what’s the latest for pspgo

    • Fargaite

      Old news.

  • CreativeMindMedias

    So yes they are working on the Un-Hackable PSP’s. You just have to give it time.

  • http://wiifriendcodes.tk McNuggetz

    time is taking a long time i want plugin support only thing pro hen can do is run iso’s >:[

    • maycee

      same here

  • FatalxShadow

    this is really exciting and when it does come out im hoping it works for everyone!

  • Kobe

    Aight, EVERYBODY, I tested it on psp 3000 ta-090 v2 and my psp got f*in bricked, luckly my bro dosent play his , so takin his, but this is a freakin warning DON’T try it on a 3000 or go cuz if my 3000 got bricked then the go will also prolly get bricked

    • James

      110% you’re fault man, sucks to be you…

    • maycee

      lol….. its either you forgot how to read or your just stupid -___-”
      its for fully hackable psp’s only at the moment

    • Slapstickskeptic

      …………………./´¯/)
      ………………..,/¯../
      ………………./…./
      …………./´¯/’…’/´¯¯`·¸
      ………./’/…/…./……./¨¯\
      ……..(‘(…´…´…. ¯~/’…’)
      ………\……………..’…../
      ……….”…\………. _.·´
      …………\…………..(
      …………..\………….\…

      • http://aol.com ClockWork

        lol

  • jieson

    dont downgrade!,stay on 6.31 or 6.35 Hen…

    • Jurian

      6.31 & 6.35 hen sucks in comparison to tn’s 6.20. and they dropped development on the 6.31, and decided to make a 6.35cfw and stopped development on the 6.35 hen. If tn made a 6.31 i would gladly stay, but that’s not happening.

  • http://www.google.com gororo

    cant wait… till it stable… i like it ^_^

  • Richard!

    when can we download it ?

    • LISTEN TO ME!!

      TONIGHT!!

  • anakingo

    this is cool!

  • http://pan.bytepub.com Side Scoop

    Davee was also making a downgrader for 6.35. He said that it worked for PSP Go, but not for other PSP models. I’m not sure if he has abandoned the project, though. Check his Twitter.

  • sonictoast

    cool

  • Gerardnr

    For PSX Emulation Search up PS1P Owned

  • Ultra

    Camera keeps on AF.. :-)

  • Pingback: Light VSH Menu for 6.35PRO released!! - Page 2 - OneHitGamer

  • LISTEN TO ME!!

    IT WILL BE RELEASED TONIGHT!!

  • http://google Uktonic

    Pleaseanswer me …….I Have the game loaded on my psp butttttttt…..when i go to the menu screen theres two items like on the video above……when i select the bottom one like in the video above……it shows the same image above (Like it loads shownigg the psp thing then instead of running the black screen)…..IT doesnt load it it takes me to a screen that i dnt know what it says……Please help me…..

  • hfvhv

    DOES THIS REALY WORK

  • FGNV

    DOES IT WORK ON 6.35 PRO?

  • http://yahoo dare devil

    hey some1 plz tell me hw 2 download this thng

  • bheism

    come on guy make downgrader 6.35 to 5.00 or 6.10 without pandora or magic memory come ooon are you????