Hellcat’s Recovery Flasher v1.65 Released.

Share

Hellcat has released his Recovery Flasher v1.65. This update has a whole new bunch of features. The list of things this can do is just massive. This can recovery semi bricked PSP’s, flash any CFW to your PSP and lots more. Of course it depends on what PSP model your using. Just make sure you read the read-me text file for this one and carefully. Remember that flashing your PSP is risky.

What is this? And why?
========================================

* Flashes a fresh M33 CFW (everyone from 3.71 up) for recovering semi-bricks or to up-/downgrade CFW
* does not use Pandora, runns from the recovery menu or the XMB
* does not use (as in launch) the original Sony Updater (only extracts all required files from the original .PBP)
* runns fine on CFWs lower than 3.52-M33-3 – handy for upgrading older FWs w/o the “need to go 3.52, then 3.52-3, then higher” odyssey :-)
* runns fine from TimeMachine (3.40-OE on Fat and 3.60-M33 on Slim)
* can backup the FW flash and restore selected parts (XMB theme, settings, PSN activation, complete firmware)
* can make and restore full NAND dumps

Recovery Flasher 1.65 changelog:

* fixed compatibility with 6.20-TN HEN
* added check for 6.20-TN and the 6.35 HEN
* added check for 6.20-TN HEN’s flash0 protection being enabled
* added check for configured game mode plugins when on 6.20-TN and the 6.35 HEN
* added detection of the PSP4000 model and the PSPgo
* added appropriate handling of all of the above, when detected, to avoid unnecessary tears casted by users
* added support to handle 6.00, 6.10 and 6.20 FWs for restore of (filewise) flash backup and clean install from scratch
* added decryption of extracted (hidden) updater driver modules – and so enabling downgrade from 6.35+ (only on hackable PSPs though, for now)
* added new firmware packs to install clean 6.20 OFW using Recovery Flasher
* bundled the existing 5.50-GEN firmware packs with the main release


Download: Hellcat's Recovery Flasher v1.65
(Hellcat's Recovery Flasher v1.65 - 2.6 MiB - 50,984 Hits)

Source: http://twitter.com/therealhellcat

Similar Posts:

  • None Found

  • Arcdejeanne

    Amazing! Semi bricked my PSP with 5.50 GEN D-3 when trying to update to 6.60ME, used this and I’m back to 5.00. Probably won’t be trying to upgrade again any time soon after that debacle lol…

    anyway THANK YOU HELLCAT!!

  • Parkerv74

    it say error there are configured game mode plugins what do i dooo?? PLEASE HELP

  • ??

    does it w,ork with psp model 1003 ??