Custom Firmware 5.03 GEN-B for HEN Released

Share
Custom Firmware 503 GEN-B released.

Custom Firmware 503 GEN-B released.

has been released. This custom firmware update for PSP-3000 / PSP-2000 TA-088v3 owners now lets users play original firmware 5.55+ games with out the need of Game Decrypter. So no more eboot patching and rebuilding ISO’s with UMDGen. Your now level with 5.50 GEN-D2 users, same options more or less.

Custom Firmware 5.03 GEN-B Release notes:

Background of core functions:

* Compatible with PSP-3000 and PSP-2000 v3 official firmware 5.03
* Play backups of games REQUIRE PSP firmware above 5.03, including 6.xx
* Reading UMD REQUIRE firmware above 5.03, including 6.xx
* Reading UMD / ISO games protected against the custom firmware.
* Play of PS1 games
* GEN available VSH MENU (SELECT)
* Recovery in VSH available
* Reading Homebrews
* Etc..

It is time to get down to that angry because we have failed to resolve.

Known Bugs:

* MGS demo refuses to run
We’ve tried everything and what works in 5.50GEN-D2 has not worked in the 5.03GEN-B. Pity …

* The Recovery mode menu is “mixed”
The RECOVERY MODE 5.02GEN-A has been patched to run on the PSP-3000. It can change the most usual options but we encounter some problems with this VSH Recovery in and we have not managed to fix it. In fact, the menu sees some of his lines not properly allocated and others who do not work. Note that on a PSP-3000, the recovery is useless, or nearly so, since all the useful features found in the VSH menu or in Ultimate VSH menu Total_Noob of Total_Noob we strongly recommend that you install.

Remember in order to update to 5.03 GEN-B you need to have 5.03 GEN-A already up and running. *Not needed you can go straight to 5.03 GEN-B. Here are some tips to get on the road to CFW 5.03 GEN-B :

  1. Ok first up you’ll need a PSP-3000 or PSP-2000 with a TA-088v3 *duh…
  2. Now make sure your running Firmware 5.03 or less (On FW 5.03+ Sorry this isn’t for ya. ChickHEN only works on 5.03!)
  3. Install chickHEN R2 and get it running. This will help: Guide to running ChickHEN R2
  4. Once in the Homebrew Enabled Environment aka HEN, run GEN-B. Simple!

Download: Custom Firmware 5.03 GEN-B
(Custom Firmware 5.03 GEN-B - 255.7 KiB - 97,967 Hits)

Oh and while your at it, Team GEN recommends you install this: Ultimate VSH Menu Revised by Total_Noob, it will give you some useful VSH Menu functions since the Recovery Menu is practically useless….

Similar Posts:

  • None Found

  • Pingback: Virus on my PSP?! - Page 2 - PSP Slim Hacks - PSP Forums

    • dsiist

      how do i go from gen-c to gen-b ?

  • markf9t

    Erm.. can anyone help me out? my psp just won’t change to 5.03gen-b(FULL). it keeps changing to 5.00M33 even after it says ‘now rebooting your software to 5.03gen-b’. anyone can help me? thanks in advance.

    • dsiist

      you need to hold the l trigger wile updating

  • rayray88

    alright now i can play nba 10 thx so much!!!

  • NarutoMorris

    Can it play the Narutimate Accel 3?

  • http://www.pspslimhacks.com Hitman@47

    yesssssss it,s s working great in my psp 2006 ta088v3 .it,s playing obscure game with out with out Game Decrypter.thanks for gen team.mmmm i kiss u

    • Fatalreaper

      but i have a problem. i downloaded the game unrar it and then put it in the iso folder. it seems to have an error when i press start. 80020148. could u help me thx

  • Fatalreaper

    when it says that GEN B can play OFW games 6.XX it means gundam vs gundam next plus too?

  • Pingback: Weird scenario...help? - PSP Slim Hacks - PSP Forums

  • Wolfdawg

    Ok I have a PSP 3000 with ofw 4.0 or 5.0 something (can you tell me how to tell?) now with fw 6.20 (ops) this will run? what this tut says?
    btw can I use an emulator like a gameboy or nin 64?

  • zaxor16

    after i installed cfw enabler 5.03 gen B.. after i have done the ritual, my psp was converted into 5.03 MHU and cant play tekken 6. please help, masers.

  • Pingback: Some Help Please - PSP Slim Hacks - PSP Forums

  • havocol1029

    Hi,i got a psp 3006 ofw is 6.20 can i mod it? reply me asap ! thanks ! (:

  • Crzyby

    does this works for psp 2000 with cfw 5.03?