Custom Firmware 3.80 M33-5 Released!

Share

Now up to update number 5 as DarK_AleX and the team release 3.80 M33-5. This update is available by the network update feature or download manually below. This update for 3.80 M33 features a fix for custom CPU clock settings in games and the option to hide the PIC0.PNG and PIC1.PNG icons in the XMB game menu. (Helps speed things up)

3.80 M33-5

Changelog:

- Fixed custom CPU clock not working in games
- CPU clock has never (in any SE/OE/M33) be set at all in games that restarted using sceKernelLoadExec to use a subgame or reload themselves,
after said restart happened (e.g. Castlevania). Fixed.
- Added setting to recovery to hide PIC0.PNG and PIC1.PNG in the XMB game menu
By default off, when on you will probably notice a faster browse in XMB games.
This setting only applies to any kind of apps/games (pbp, iso) that load from MS, but not to UMD’s.

Similar Posts:

Gamer Headlines
  • Pingback: Custom Firmware 3.80 M33-5 Released! | Console Hacks Network

  • Matt

    Just want to thank Dark_Alex for all his work. Another update, and it’s only been a few days! And I must say I LOVE the ability to download new M33 updates though Network Update.

  • PJ

    I’m having a problem playing FF7 PS1 game. When I run the game in 3.80 M33-5, during the battle scenes, there are lines all over the screen, then afterwards, the text becomes all distorted. I reflashed my psp to 3.71 M33-2 and upgraded to M33-3 and tried it, it worked fine, and i upgraded to M33-4 and it works fine. I suspect it has to do with 3.80 version.

  • Jim

    So tempted to download, but 3 things:
    - Will I lose any data when upgrading from 3.71 M33-4?
    - Are there any compatibility issues with 3.8?
    - If all is good and I upgrade to 3.8, do I install all 5 upgrades, or are they cumulative?

    Thanks for your help

  • nate

    pj:dude,get the latest popsloader for 3.80 m33 pls…

  • Neil

    Are CPS1/2 and NeoGeo emulators still on the fritz?

  • http://Dunno ZeroX
  • Babz

    hi i just bought a psp slim with firmware 3.71, i bought my self a pandora battery, could you please help me and explain to me how to make a magic memory card and what downloads i need and how to do it, i would really appreciate it, i have been trying and i cant seem to do it, cheers, could you email me please

  • PJ

    Zerox, i just sent you an email.
    I’m using the psp slim 3.71 M33-4 at the moment. No popsloader.

    running the game fine.
    but when I upgrade to 3.80 m33. That’s when the glitches come out.
    I’ll try get a screenshot tomorrow.

  • http://Dunno ZeroX

    You must use Popsloader v2 to enable everything, first install Popsloader v2 then follow my instructions in the email.

  • diablo

    got 3.80 m33 installed and gotta say custom network update rocks butalso gotta say even know i got the latest update and the latest popsloaader installed it still crashes my slim on occasion mostly after copying files to the memory stick :(

  • Nickky

    I’ve just downloaded 3.80 m33-5 CFW and 3.80 M33 v2 popsloader from http://www.dark-alex.org/.I wonder if i can play ps1:FFVII which I just downloaded? Seems to be a lot of people are having problem with this CFW? Is the latest pops still not compatible?

  • Super_Jedi7

    I notic that sleep mode wont work during any homebrews…when I turn my psp back out of sleep it jsut hard boots….

  • NeedHelpBadly

    I need help with emulations etc. the whole psp hack thing. Why is it everytime I download a file like the new cfw why is it all gibberish what am I supposed to do with that? And do I need the 1.50 kernel thing that I don’t even know where to get?

  • NeedHelpBadly

    Why is it everytime I download a file like the new cfw why is it all gibberish what am I supposed to do with that? And do I need the 1.50 kernel thing that I don’t even know where to get?

  • http://teamjinchuuriki.mygameclan.com Jean Paul

    i just bought a brand new PSP that is not slim.. And it already have 3.80 M33-5 system firmware. Is my system software different from your custom firmware 3.80 M33-5.. dude help me im getting confusedd

  • IoN

    i have a psp that not slim but is 3.71 M33- 4 and i downloaded both 3.80 M33- 5 and the V2 and tried updating but it just and says before that This program can only be executed on 3.80 M33.

  • WhoCares

    I have PSP slim with 3.80 M33-5. I want to upgrade it to 3.90 M33-2.. but when i start do upgrade.. It always say Incorrect file.. What should i do?? can anyone who can help me??

  • i care

    hey i just downloaded 3.80 M33-5
    wen i run it it says.
    game could not be started (80020148)
    any help plz??

  • Wiwi_M
  • Steve831

    What are my requirements for this installation? Is a Pandora battery manditory???

  • tsannang

    ITJUYEGTIZGYZEFGHIZ

  • Albhle

    goood